GETTIN' DIRTY IN THE 'VILLE
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist    Merchandise  Local Junkyards  Local Offroad Parks  RegisterRegister  Log inLog in  
CHECK OUT OUR NEW ONLINE STORE UNDER THE "MERCHANDISE" LINK AT THE TOP OF THE PAGE!!
Like us on Facebook!

Add to Favorites

Latest topics
» Any one on here ?
8th March 2015, 4:57 pm by Jason y

» Trail Rated lol
11th November 2013, 2:40 am by Legg

» New member
11th November 2013, 2:34 am by Legg

» 38.5x15x15 bogger 200.00
13th July 2013, 11:07 am by 72Blazerracer

» Slower-poke Build. 98 ZJ 5.9 Limited
2nd July 2013, 3:01 pm by gs69350

» FREE T-SHIRT
15th April 2013, 1:07 pm by gs69350

» My Solid Axle Swap build
7th April 2013, 8:18 pm by fishforlife2007

» stripping an xj lol
7th April 2013, 8:04 pm by fishforlife2007

» LJOC's Guns N Jeeps Meet
7th April 2013, 3:22 pm by ZJ_flexxxer

» Black Betty, my 95 YJ Build thread
2nd April 2013, 9:48 pm by ZJ_flexxxer

Top posting users this month
Your ad here!



Share | 
 

 K10 Starter Problem

Go down 
AuthorMessage
sfrazier

avatar

Posts : 2
Points : 6
Join date : 2012-01-26
Location : Brandenburg, KY

PostSubject: K10 Starter Problem   27th January 2012, 10:40 pm

Anybody have a problem with the starter twisting on a high compression motor before. My truck has a 383 stroker motor in it and the starter keeps jamming. I have to climb under it unbolt it and turn the flywheel and then bolt it back up. Really annoying. How do I fix this? Will shimming it work?
Back to top Go down
View user profile
fishforlife2007

avatar

Posts : 10
Points : 12
Join date : 2012-01-27

PostSubject: Re: K10 Starter Problem   27th January 2012, 10:48 pm

it almost sounds like its not fully engaging on the flywheel, or its the wrong starter.

__________________________________________________
95 F150 solid axled swapped, sterling 10.25 in the rear and a d44hd in the front. heavy duty zf trans swapped in running on 37'' militarys
Back to top Go down
View user profile
lil_instgator

avatar

Posts : 10
Points : 12
Join date : 2012-01-25
Age : 40
Location : Leitchfield, Ky

PostSubject: Re: K10 Starter Problem   28th January 2012, 12:13 am

does it have the brace from the back of the starter to the side of the block alot of people leave them off not knowing any better
Back to top Go down
View user profile http://www.sackupoffroad.com
killzone90



Posts : 125
Points : 152
Join date : 2012-01-25

PostSubject: Re: K10 Starter Problem   28th January 2012, 1:05 am

thats the wrong starter did the same thing one my 383 race motor
Back to top Go down
View user profile
kymudhunter

avatar

Posts : 108
Points : 132
Join date : 2012-01-29

PostSubject: Re: K10 Starter Problem   29th January 2012, 11:08 am

The nose cone bushing sound wore out to me. Used to do that on my 454 all the time. wore the boshing out by not shimming the starter when first put on.
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: K10 Starter Problem   

Back to top Go down
 
K10 Starter Problem
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
502OFFROAD.COM :: Technical :: Problem Solving/Questions-
Jump to: